Salsah Documentation logo Salsah Documentation
v2.0.0-alpha.14

We develop the Salsah app with Angular (v5), especially with Angular-cli, which requires the following tools:

Node

Install Node in version >=4 <=9. We recommend to use version 8.9.0.

The easiest way to install node in the correct version is to use ā€˜nā€™.

Yarn (instead of npm)

By installing node, you get the node package manager (npm), which will be used for the app dependency management. But we recommend to use yarn instead of npm.

Install yarn by following the instructions on their website.

Angular-cli

To start the app or to create new components and services, you need angular-cli, which should be installed globally.

$ yarn global add @angular/cli

ā†’ Start the app